代码之家(www.adminjie.com)精品网站源码,微信源码,游戏源码分享平台。《交流群:1037940574》
当前位置:网站首页 技术文章 网络编程 正文

低版本VS项目在VS2019无法正常编译的问题

时间:2020-08-21 [网络编程]作者:adminjie 浏览:68 次

低版本VS项目在VS2019无法正常编译的问题

这里指的编译并不准确,只是为了方便说明。

今天新装了VS2019想换个新环境,打开原来项目的时候发现大量报错,而项目原本是没有问题的,想着是可能由于VS2019升级了编译器(对应版本:

Microsoft.CodeDom.Providers.DotNetCompilerPlatform.2.0.0),上网查找后知道解决办法,记录在下。

问题说明

低版本VS项目在VS2019无法正常编译的问题  2

低版本VS项目在VS2019无法正常编译的问题  2

主要表现为:

错误列表中大量 “无法打开源文件”错误资源列表中许多文件无法包含前两个问题导致的代码中问题(格式、类型声明、定义等)解决方法

主要原因是开发平台工具集的缺失,VS2019不自动下载之前版本的工具集(安装时未主动选择的话)。

1、找到所需工具集版本

解决方案→项目属性→常规:平台工具集

低版本VS项目在VS2019无法正常编译的问题  2

图片中为解决后的界面,实际情况应为列表中有VS 2019(v142)和VS 201?(v140),且VS 201?后有(未安装),201?指项目原本开发工具

2、下载所需工具集

工具→获取工具和功能→可用→单个组件:往下翻找到“编译器、生成工具和运行时”,在其中选择对应工具集

低版本VS项目在VS2019无法正常编译的问题  2

比如我缺失的是VS 2015(v140)

安装后,在之前属性界面即可选择对应工具集

参考:https://www.wandouip.com/t5i207272/


转载请注明来源:低版本VS项目在VS2019无法正常编译的问题

本文永久链接地址:https://www.adminjie.com/post/3621.html

免责声明:
本站所发布的一切资源仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序,请支持正版软件,购买注册,得到更好的正版服务。

附:
二○○二年一月一日《计算机软件保护条例》第十七条规定:为了学习和研究软件内含的设计思想和原理,通过安装、显示、传输或者存储软件等方式使用软件的,可以不经软件著作权人许可,不向其支付报酬!鉴于此,也希望大家按此说明研究软件!

版权声明:
一、本站致力于为软件爱好者提供国内外软件开发技术和软件共享,着力为用户提供优资资源。
二、本站提供的部分源码下载文件为网络共享资源,请于下载后的24小时内删除。如需体验更多乐趣,还请支持正版。
三、我站提供用户下载的所有内容均转自互联网。如有内容侵犯您的版权或其他利益的,若有侵犯你的权益请:点此维权 站长会进行审查之后,情况属实的会在三个工作日内为您删除。

  • 代码之家会员升级
  • 最新文章
  • 阿里云大优惠
  • 热门文章